diff options
author | Lance Stout <lancestout@gmail.com> | 2011-08-05 14:06:58 -0700 |
---|---|---|
committer | Lance Stout <lancestout@gmail.com> | 2011-08-05 14:06:58 -0700 |
commit | 148a23579c199d218325c88d7b6f567f42c7a36a (patch) | |
tree | 82c9d0b3d4b54ad5e5016a954bc35b4d2c72ec9f /setup.py | |
parent | 168203c94def5b4f88345e2564ecb0b973e8fc3f (diff) | |
download | slixmpp-sleek-1.0-Beta6.1.tar.gz slixmpp-sleek-1.0-Beta6.1.tar.bz2 slixmpp-sleek-1.0-Beta6.1.tar.xz slixmpp-sleek-1.0-Beta6.1.zip |
Hotfix for ANONYMOUS mech support.sleek-1.0-Beta6.11.0-Beta6.1
Updates version to 1.0-Beta6.1
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 15 |
1 files changed, 9 insertions, 6 deletions
@@ -1,7 +1,7 @@ #!/usr/bin/env python
# -*- coding: utf-8 -*-
#
-# Copyright (C) 2007-2008 Nathanael C. Fritz
+# Copyright (C) 2007-2011 Nathanael C. Fritz
# All Rights Reserved
#
# This software is licensed as described in the README file,
@@ -29,13 +29,16 @@ import sleekxmpp VERSION = sleekxmpp.__version__
DESCRIPTION = 'SleekXMPP is an elegant Python library for XMPP (aka Jabber, Google Talk, etc).'
-LONG_DESCRIPTION = """
-SleekXMPP is an elegant Python library for XMPP (aka Jabber, Google Talk, etc).
-"""
+with open('README') as readme:
+ LONG_DESCRIPTION = '\n'.join(readme)
CLASSIFIERS = [ 'Intended Audience :: Developers',
- 'License :: OSI Approved :: MIT',
+ 'License :: OSI Approved :: MIT License',
'Programming Language :: Python',
+ 'Programming Language :: Python 2.6',
+ 'Programming Language :: Python 2.7',
+ 'Programming Language :: Python 3.1',
+ 'Programming Language :: Python 3.2',
'Topic :: Software Development :: Libraries :: Python Modules',
]
@@ -82,7 +85,7 @@ setup( long_description = LONG_DESCRIPTION,
author = 'Nathanael Fritz',
author_email = 'fritzy [at] netflint.net',
- url = 'http://code.google.com/p/sleekxmpp',
+ url = 'http://github.com/fritzy/SleekXMPP',
license = 'MIT',
platforms = [ 'any' ],
packages = packages,
|