summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index d1dde4d2..8c9fa723 100755
--- a/setup.py
+++ b/setup.py
@@ -125,8 +125,8 @@ setup(
long_description=LONG_DESCRIPTION,
ext_modules=[module_poopt],
url='https://poez.io/',
- license='zlib',
- download_url='https://poez.io/#download',
+ license='GPL-3.0-or-later',
+ download_url='https://dev.louiz.org/projects/poezio/files',
author='Florent Le Coz',
author_email='louiz@louiz.org',
@@ -139,7 +139,7 @@ setup(
'Topic :: Internet :: XMPP',
'Environment :: Console :: Curses',
'Intended Audience :: End Users/Desktop',
- 'License :: OSI Approved :: zlib/libpng License',
+ 'License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)',
'Natural Language :: English',
'Operating System :: Unix',
'Programming Language :: Python :: 3.9',
@@ -152,7 +152,7 @@ setup(
package_dir={'poezio': 'poezio',
'poezio_plugins': 'plugins',
'poezio_themes': 'data/themes'},
- package_data={'poezio': ['default_config.cfg']},
+ package_data={'poezio': ['default_config.cfg', 'py.typed']},
scripts=['scripts/poezio_logs'],
entry_points={'console_scripts': ['poezio = poezio.__main__:run']},
data_files=([