summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py26
1 files changed, 16 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 9e8ee2ad..c6746336 100644
--- a/setup.py
+++ b/setup.py
@@ -14,15 +14,17 @@ if not os.path.exists(os.path.join(current_dir, 'src', 'default_config.cfg')):
os.path.join(current_dir, 'src', 'default_config.cfg'))
setup(name="poezio",
- version="0.8",
+ version="0.8.1",
description="A console XMPP client",
long_description=
- """
- Poezio is a Free chat client aiming to reproduce the ease of use of most
- IRC clients (e.g. weechat, irssi) while using the XMPP network.
- """,
+ "Poezio is a Free chat client aiming to reproduce the ease of use of most "
+ "IRC clients (e.g. weechat, irssi) while using the XMPP network."
+ "\n"
+ "Documentation is available at http://doc.poez.io/0.8.",
+
+
ext_modules = [module_poopt],
- url = 'http://poezio.eu/',
+ url = 'http://poez.io/',
license = 'zlib',
author = 'Florent Le Coz',
@@ -31,22 +33,26 @@ setup(name="poezio",
maintainer = 'Mathieu Pasquet',
maintainer_email = 'mathieui@mathieui.net',
- classifiers = ['Development Status :: 5 - Production/Stable',
+ classifiers = [ 'Development Status :: 4 - Beta',
'Environment :: Console :: Curses',
'Intended Audience :: End Users/Desktop',
'License :: OSI Approved :: zlib/libpng License',
'Natural Language :: English',
'Operating System :: Unix',
'Topic :: Communications :: Chat',
- 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3'
],
keywords = ['jabber', 'xmpp', 'client', 'chat', 'im', 'console'],
packages = ['poezio', 'poezio_plugins', 'poezio_plugins.gpg', 'poezio_themes'],
package_dir = {'poezio': 'src', 'poezio_plugins': 'plugins', 'poezio_themes': 'data/themes'},
package_data = {'poezio': ['default_config.cfg']},
scripts = ['scripts/poezio'],
- data_files = [('share/poezio/themes/', ['data/themes/dark.py']),
- ('share/man/man1/', ['data/poezio.1'])],
+ data_files = [('share/man/man1/', ['data/poezio.1'])],
+
+ install_requires = ['sleekxmpp==1.2.4',
+ 'dnspython3>=1.11.1'],
+ extras_require = {'OTR plugin': 'python-potr>=1.0',
+ 'Screen autoaway plugin': 'pyinotify==0.9.4'}
)
# Remove the link afterwards