summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 6 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 6c70c208..efd914b0 100755
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,13 @@
#!/usr/bin/env python3
+
try:
from setuptools import setup, Extension
except ImportError:
+ print('Setuptools was not found.\n'
+ 'This script will use distutils instead, which will NOT'
+ ' be able to install a `poezio` executable.\nIf you are '
+ 'using it to build a package or install poezio, please '
+ 'install setuptools.\n\nYou will also see a few warnings.\n')
from distutils.core import setup, Extension
import os