summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2011-09-11 04:22:04 +0200
committerFlorent Le Coz <louiz@louiz.org>2011-09-11 04:22:04 +0200
commitb7b1faebdb52e8f041867f19f29a08f64cfaf220 (patch)
tree180c45399c1907c853bdf25585ec203c04fc8e9e /setup.py
parent78c216cd61ab96f7476ce194323517b73b8ee04c (diff)
parentce1fb8af014e90cfc7378022c8cbdd134e45ed4a (diff)
downloadpoezio-b7b1faebdb52e8f041867f19f29a08f64cfaf220.tar.gz
poezio-b7b1faebdb52e8f041867f19f29a08f64cfaf220.tar.bz2
poezio-b7b1faebdb52e8f041867f19f29a08f64cfaf220.tar.xz
poezio-b7b1faebdb52e8f041867f19f29a08f64cfaf220.zip
merge
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 16 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 00000000..50d787da
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,16 @@
+from distutils.core import setup, Extension
+
+module_poopt = Extension('poopt',
+ sources = ['src/pooptmodule.c'])
+
+setup (name = 'BuildLines',
+ version = '0.0.1',
+ description = 'Poezio Optimizations',
+ ext_modules = [module_poopt],
+ author = 'Florent Le Coz',
+ author_email = 'louiz@louiz.org',
+ long_description = """
+ a python3 module for poezio, used to replace some time-critical
+ python functions that are too slow. If compiled, poezio will use this module,
+ otherwise it will just use the equivalent python functions.
+ """)