summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authormathieui <mathieui@mathieui.net>2013-05-26 20:07:12 +0200
committermathieui <mathieui@mathieui.net>2013-05-26 20:13:39 +0200
commit2b42c6a3ead7c2bd35bbea1c6d704a4f89a4c8a2 (patch)
tree10a77ef05670ec575e2c3357e0b3df9b0847a261 /setup.py
parent1b9dc72d14f52d55a936d92311c18912567359a4 (diff)
downloadpoezio-2b42c6a3ead7c2bd35bbea1c6d704a4f89a4c8a2.tar.gz
poezio-2b42c6a3ead7c2bd35bbea1c6d704a4f89a4c8a2.tar.bz2
poezio-2b42c6a3ead7c2bd35bbea1c6d704a4f89a4c8a2.tar.xz
poezio-2b42c6a3ead7c2bd35bbea1c6d704a4f89a4c8a2.zip
Update setup.py to use distutils
(use new default directory, install the plugins as a separate python moduleā€¦)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py44
1 files changed, 34 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 31ccc5a6..b223b5e3 100644
--- a/setup.py
+++ b/setup.py
@@ -1,16 +1,40 @@
from distutils.core import setup, Extension
-module_poopt = Extension('poopt',
- sources = ['pooptmodule.c'])
+module_poopt = Extension('poezio.poopt',
+ sources = ['src/pooptmodule.c'])
-setup (name = 'BuildLines',
- version = '0.0.1',
- description = 'Poezio Optimizations',
+setup(name="poezio",
+ version="0.8-dev",
+ description="A console XMPP client",
+ long_description=
+ """
+ Poezio is a free chat client aiming to reproduce the ease of use of most
+ IRC clients (e.g. weechat, irssi) while using the XMPP network.
+ """,
ext_modules = [module_poopt],
+ url = 'http://poezio.eu/',
+ license = 'zlib',
+
author = 'Florent Le Coz',
author_email = 'louiz@louiz.org',
- long_description = """
- a python3 module for poezio, used to replace some time-critical
- python functions that are too slow. If compiled, poezio will use this module,
- otherwise it will just use the equivalent python functions.
- """)
+
+ maintainer = 'Mathieu Pasquet',
+ maintainer_email = 'mathieui@mathieui.net',
+
+ classifiers = ['Development Status :: 4 - Beta',
+ 'Environment :: Console :: Curses',
+ 'Intended Audience :: End Users/Desktop',
+ 'License :: OSI Approved :: zlib/libpng License',
+ 'Natural Language :: English',
+ 'Operating System :: Unix',
+ 'Topic :: Communications :: Chat',
+ 'Programming Language :: Python :: 3',
+ ],
+ keywords = ['xmpp', 'chat', 'im', 'console'],
+ packages = ['poezio', 'poezio_plugins'],
+ package_dir = {'poezio': 'src', 'poezio_plugins': 'plugins'},
+ scripts = ['scripts/poezio'],
+ data_files = [('/etc/poezio/', ['data/default_config.cfg']),
+ ('share/poezio/themes/', ['data/themes/dark.py']),
+ ('share/man/man1/', ['data/poezio.1'])],
+)