summaryrefslogtreecommitdiff
path: root/docker/biboumi-test/debian/Dockerfile
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2019-09-17 17:20:46 +0200
committerlouiz’ <louiz@louiz.org>2019-09-17 17:20:46 +0200
commitb5f7e599e0d2a5569d9ce4627cec5243827936f7 (patch)
treeaf3790a3d83c566bbc57bfd491890f59893d6026 /docker/biboumi-test/debian/Dockerfile
parent2f0078ebfc453d9f40ea317a718e805ccd92a476 (diff)
downloadbiboumi-b5f7e599e0d2a5569d9ce4627cec5243827936f7.tar.gz
biboumi-b5f7e599e0d2a5569d9ce4627cec5243827936f7.tar.bz2
biboumi-b5f7e599e0d2a5569d9ce4627cec5243827936f7.tar.xz
biboumi-b5f7e599e0d2a5569d9ce4627cec5243827936f7.zip
Update the images and .spec to use sphinx instead of pandoc
Diffstat (limited to 'docker/biboumi-test/debian/Dockerfile')
-rw-r--r--docker/biboumi-test/debian/Dockerfile8
1 files changed, 4 insertions, 4 deletions
diff --git a/docker/biboumi-test/debian/Dockerfile b/docker/biboumi-test/debian/Dockerfile
index 557face..1c6437c 100644
--- a/docker/biboumi-test/debian/Dockerfile
+++ b/docker/biboumi-test/debian/Dockerfile
@@ -1,7 +1,7 @@
# This Dockerfile creates a docker image suitable to run biboumi’s build and
# tests. For example, it can be used on with gitlab-ci.
-FROM docker.io/debian:latest
+FROM docker.io/debian:buster
ENV LC_ALL C.UTF-8
@@ -22,8 +22,8 @@ RUN apt install -y g++\
libidn11-dev\
uuid-dev\
libsystemd-dev\
- pandoc\
- libasan3\
+ python3-sphinx\
+ libasan5\
libubsan0\
git\
python3-lxml\
@@ -46,7 +46,7 @@ RUN apt install -y g++\
RUN git clone https://github.com/randombit/botan.git && cd botan && ./configure.py --prefix=/usr && make -j8 && make install && rm -rf /botan
# Install slixmpp, for e2e tests
-RUN git clone https://github.com/saghul/aiodns.git && cd aiodns && git checkout 7ee13f9bea25784322~ && python3 setup.py build && python3 setup.py install && git clone git://git.louiz.org/slixmpp && pip3 install pyasn1==0.4.2 && cd slixmpp && python3 setup.py build && python3 setup.py install
+RUN git clone https://github.com/saghul/aiodns.git && cd aiodns && git checkout 7ee13f9bea25784322~ && python3 setup.py build && python3 setup.py install && git clone git://git.louiz.org/slixmpp && pip3 install pyasn1 && cd slixmpp && python3 setup.py build && python3 setup.py install
RUN useradd tester -m