summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f6eace7f..ba61c84e 100644
--- a/setup.py
+++ b/setup.py
@@ -44,10 +44,14 @@ packages = [ 'sleekxmpp',
'sleekxmpp/xmlstream',
'sleekxmpp/xmlstream/matcher',
'sleekxmpp/xmlstream/handler',
- 'sleekxmpp/xmlstream/tostring',
'sleekxmpp/thirdparty',
]
+if sys.version_info < (3, 0):
+ py_modules = ['sleekxmpp.xmlstream.tostring.tostring26']
+else:
+ py_modules = ['sleekxmpp.xmlstream.tostring.tostring']
+
setup(
name = "sleekxmpp",
version = VERSION,