diff options
author | mathieui <mathieui@mathieui.net> | 2021-04-20 09:27:10 +0200 |
---|---|---|
committer | mathieui <mathieui@mathieui.net> | 2021-04-20 09:27:10 +0200 |
commit | 7f0febb929b0db51f300a2986be98af3ff32ca79 (patch) | |
tree | e6697fff32af7c4ff51b8eacbebc4d814320c023 /setup.py | |
parent | 0d52344a31d67b9899b551cc1ef551def4b98eea (diff) | |
parent | 44392fa2d993a6bb2d64b08b56bddec6daed5d5f (diff) | |
download | slixmpp-7f0febb929b0db51f300a2986be98af3ff32ca79.tar.gz slixmpp-7f0febb929b0db51f300a2986be98af3ff32ca79.tar.bz2 slixmpp-7f0febb929b0db51f300a2986be98af3ff32ca79.tar.xz slixmpp-7f0febb929b0db51f300a2986be98af3ff32ca79.zip |
Merge branch 'use-runpy-for-version-data' into 'master'
fix: use runpy to get versiion-data
See merge request poezio/slixmpp!158
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 6 |
1 files changed, 4 insertions, 2 deletions
@@ -7,6 +7,7 @@ # This software is licensed as described in the README.rst and LICENSE # file, which you should have received as part of this distribution. +import runpy import os from pathlib import Path from subprocess import call, DEVNULL, check_output, CalledProcessError @@ -17,9 +18,10 @@ except ImportError: from distutils.core import setup from run_tests import TestCommand -from slixmpp.version import __version__ -VERSION = __version__ +version_mod = runpy.run_path('slixmpp/version.py') +VERSION = version_mod['__version__'] + DESCRIPTION = ('Slixmpp is an elegant Python library for XMPP (aka Jabber).') with open('README.rst', encoding='utf8') as readme: LONG_DESCRIPTION = readme.read() |