summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLance Stout <lancestout@gmail.com>2011-08-04 11:41:36 -0700
committerLance Stout <lancestout@gmail.com>2011-08-04 11:41:36 -0700
commitb9764cc120c48576be1fe6cadb11813d12f91f4c (patch)
tree312838d38935e3c8977d81db09294b37d2e08cda /setup.py
parent7cd39a6aad5d3e4cb537bf2ab3ec12a1c55c811e (diff)
downloadslixmpp-b9764cc120c48576be1fe6cadb11813d12f91f4c.tar.gz
slixmpp-b9764cc120c48576be1fe6cadb11813d12f91f4c.tar.bz2
slixmpp-b9764cc120c48576be1fe6cadb11813d12f91f4c.tar.xz
slixmpp-b9764cc120c48576be1fe6cadb11813d12f91f4c.zip
Clean up and unify tostring once and for all.
Packaging for Python3 just got easier.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 0 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 572dd1f0..42b7dfab 100644
--- a/setup.py
+++ b/setup.py
@@ -70,11 +70,6 @@ packages = [ 'sleekxmpp',
'sleekxmpp/thirdparty/suelta/mechanisms',
]
-if sys.version_info < (3, 0):
- py_modules = ['sleekxmpp.xmlstream.tostring.tostring26']
-else:
- py_modules = ['sleekxmpp.xmlstream.tostring.tostring']
-
setup(
name = "sleekxmpp",
version = VERSION,
@@ -86,7 +81,6 @@ setup(
license = 'MIT',
platforms = [ 'any' ],
packages = packages,
- py_modules = py_modules,
requires = [ 'tlslite', 'pythondns' ],
)