summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLance Stout <lancestout@gmail.com>2011-08-04 00:07:30 -0700
committerLance Stout <lancestout@gmail.com>2011-08-04 00:07:30 -0700
commita0767f6af61bc9c54b2526cd51aef7af4e383e90 (patch)
tree9004b290fc7870ba062032d4fa2cafe425b49d7b /setup.py
parent9ffdba8643ca8e52a30ce227331cd772a5fea6d1 (diff)
downloadslixmpp-a0767f6af61bc9c54b2526cd51aef7af4e383e90.tar.gz
slixmpp-a0767f6af61bc9c54b2526cd51aef7af4e383e90.tar.bz2
slixmpp-a0767f6af61bc9c54b2526cd51aef7af4e383e90.tar.xz
slixmpp-a0767f6af61bc9c54b2526cd51aef7af4e383e90.zip
Sadly, dateutil is not actually part of the standard lib.
Thus, using the XEP-0082 and XEP-0202 introduces a dependency on the dateutil package (installable using pip install python-dateutil). Maybe we'll be able to rework how these plugins work to avoid needing dateutil, but for now this will have to do.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 572dd1f0..48d88690 100644
--- a/setup.py
+++ b/setup.py
@@ -54,11 +54,15 @@ packages = [ 'sleekxmpp',
'sleekxmpp/plugins/xep_0059',
'sleekxmpp/plugins/xep_0060',
'sleekxmpp/plugins/xep_0060/stanza',
+ 'sleekxmpp/plugins/xep_0066',
'sleekxmpp/plugins/xep_0085',
'sleekxmpp/plugins/xep_0086',
'sleekxmpp/plugins/xep_0092',
'sleekxmpp/plugins/xep_0128',
- 'sleekxmpp/plugins/xep_0199',
+ 'sleekxmpp/plugins/xep_0202',
+ 'sleekxmpp/plugins/xep_0203',
+ 'sleekxmpp/plugins/xep_0224',
+ 'sleekxmpp/plugins/xep_0249',
'sleekxmpp/features',
'sleekxmpp/features/feature_mechanisms',
'sleekxmpp/features/feature_mechanisms/stanza',