summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLance Stout <lancestout@gmail.com>2011-08-12 16:47:58 -0700
committerLance Stout <lancestout@gmail.com>2011-08-12 16:47:58 -0700
commit484efff156e344fc3ca1a7377539132b702c0c78 (patch)
treefa051515b9dc15eb3a5ab1a8e8b9c2e25b920d17 /setup.py
parent89cffd43f48cfc835b70e137776eb8c2e73a0b67 (diff)
parent8f1d0e7a79b662e5f2849cea6e73716cc887e226 (diff)
downloadslixmpp-484efff156e344fc3ca1a7377539132b702c0c78.tar.gz
slixmpp-484efff156e344fc3ca1a7377539132b702c0c78.tar.bz2
slixmpp-484efff156e344fc3ca1a7377539132b702c0c78.tar.xz
slixmpp-484efff156e344fc3ca1a7377539132b702c0c78.zip
Merge branch 'develop' into roster
Conflicts: setup.py sleekxmpp/clientxmpp.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py32
1 files changed, 18 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index db85f62d..940b1e89 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,7 @@
#!/usr/bin/env python
# -*- coding: utf-8 -*-
#
-# Copyright (C) 2007-2008 Nathanael C. Fritz
+# Copyright (C) 2007-2011 Nathanael C. Fritz
# All Rights Reserved
#
# This software is licensed as described in the README file,
@@ -29,24 +29,28 @@ import sleekxmpp
VERSION = sleekxmpp.__version__
DESCRIPTION = 'SleekXMPP is an elegant Python library for XMPP (aka Jabber, Google Talk, etc).'
-LONG_DESCRIPTION = """
-SleekXMPP is an elegant Python library for XMPP (aka Jabber, Google Talk, etc).
-"""
+with open('README') as readme:
+ LONG_DESCRIPTION = '\n'.join(readme)
CLASSIFIERS = [ 'Intended Audience :: Developers',
- 'License :: OSI Approved :: MIT',
+ 'License :: OSI Approved :: MIT License',
'Programming Language :: Python',
+ 'Programming Language :: Python 2.6',
+ 'Programming Language :: Python 2.7',
+ 'Programming Language :: Python 3.1',
+ 'Programming Language :: Python 3.2',
'Topic :: Software Development :: Libraries :: Python Modules',
]
packages = [ 'sleekxmpp',
'sleekxmpp/stanza',
'sleekxmpp/test',
+ 'sleekxmpp/roster'
'sleekxmpp/xmlstream',
'sleekxmpp/xmlstream/matcher',
'sleekxmpp/xmlstream/handler',
'sleekxmpp/plugins',
- 'sleekxmpp/plugins/xep_0009',
+ 'sleekxmpp/plugins/xep_0009'
'sleekxmpp/plugins/xep_0009/stanza',
'sleekxmpp/plugins/xep_0030',
'sleekxmpp/plugins/xep_0030/stanza',
@@ -54,11 +58,17 @@ packages = [ 'sleekxmpp',
'sleekxmpp/plugins/xep_0059',
'sleekxmpp/plugins/xep_0060',
'sleekxmpp/plugins/xep_0060/stanza',
+ 'sleekxmpp/plugins/xep_0066',
+ 'sleekxmpp/plugins/xep_0078',
'sleekxmpp/plugins/xep_0085',
'sleekxmpp/plugins/xep_0086',
'sleekxmpp/plugins/xep_0092',
'sleekxmpp/plugins/xep_0128',
'sleekxmpp/plugins/xep_0199',
+ 'sleekxmpp/plugins/xep_0202',
+ 'sleekxmpp/plugins/xep_0203',
+ 'sleekxmpp/plugins/xep_0224',
+ 'sleekxmpp/plugins/xep_0249',
'sleekxmpp/features',
'sleekxmpp/features/feature_mechanisms',
'sleekxmpp/features/feature_mechanisms/stanza',
@@ -70,11 +80,6 @@ packages = [ 'sleekxmpp',
'sleekxmpp/thirdparty/suelta/mechanisms',
]
-if sys.version_info < (3, 0):
- py_modules = ['sleekxmpp.xmlstream.tostring.tostring26']
-else:
- py_modules = ['sleekxmpp.xmlstream.tostring.tostring']
-
setup(
name = "sleekxmpp",
version = VERSION,
@@ -82,10 +87,9 @@ setup(
long_description = LONG_DESCRIPTION,
author = 'Nathanael Fritz',
author_email = 'fritzy [at] netflint.net',
- url = 'http://code.google.com/p/sleekxmpp',
+ url = 'http://github.com/fritzy/SleekXMPP',
license = 'MIT',
platforms = [ 'any' ],
packages = packages,
- py_modules = py_modules,
requires = [ 'tlslite', 'pythondns' ],
- )
+)