summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authormathieui <mathieui@mathieui.net>2015-06-22 23:56:05 +0200
committermathieui <mathieui@mathieui.net>2015-06-22 23:56:05 +0200
commitd0ad25745a81df3f49a96bee376f9d60f490bd0f (patch)
tree95e6dc733f0732708e5c33cf0e36280e463b25b9 /setup.py
parentf7164d35d29041790be8b9fcd77dd89f75aee789 (diff)
parent55be23a6da0800bc7a360b2d4488ebb75bae8f89 (diff)
downloadslixmpp-d0ad25745a81df3f49a96bee376f9d60f490bd0f.tar.gz
slixmpp-d0ad25745a81df3f49a96bee376f9d60f490bd0f.tar.bz2
slixmpp-d0ad25745a81df3f49a96bee376f9d60f490bd0f.tar.xz
slixmpp-d0ad25745a81df3f49a96bee376f9d60f490bd0f.zip
Merge branch 'jid' of http://git.linkmauve.fr/slixmpp
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py9
1 files changed, 9 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index ca8be7f5..56fdc76e 100755
--- a/setup.py
+++ b/setup.py
@@ -13,6 +13,14 @@ try:
except ImportError:
from distutils.core import setup
+try:
+ from Cython.Build import cythonize
+except ImportError:
+ print('Cython not found, falling back to the slow stringprep module.')
+ ext_modules = None
+else:
+ ext_modules = cythonize('slixmpp/stringprep.pyx')
+
from run_tests import TestCommand
from slixmpp.version import __version__
@@ -43,6 +51,7 @@ setup(
license='MIT',
platforms=['any'],
packages=packages,
+ ext_modules=ext_modules,
requires=['aiodns', 'pyasn1', 'pyasn1_modules'],
classifiers=CLASSIFIERS,
cmdclass={'test': TestCommand}