diff options
author | Lance Stout <lancestout@gmail.com> | 2011-08-24 21:54:36 -0700 |
---|---|---|
committer | Lance Stout <lancestout@gmail.com> | 2011-08-24 22:09:02 -0700 |
commit | ede59ab40e896293adba1278c42463fd8a5ba0fa (patch) | |
tree | 674d619648a97ea2bfea3d77199392d4ed750435 /setup.py | |
parent | 2a8082407656bf78a487afcf20017b10ca6475cc (diff) | |
download | slixmpp-ede59ab40e896293adba1278c42463fd8a5ba0fa.tar.gz slixmpp-ede59ab40e896293adba1278c42463fd8a5ba0fa.tar.bz2 slixmpp-ede59ab40e896293adba1278c42463fd8a5ba0fa.tar.xz slixmpp-ede59ab40e896293adba1278c42463fd8a5ba0fa.zip |
Clean and get setup.py working once and for all.
Fixes:
README.rst now included
Double line spacing removed from long_description
Source package now includes tests, examples, etc using Manifest.in
README.rst typos fixed
Added README.rst section on installing dnspython for Python3
Version bumped to RC2
Version is now taken from sleekxmpp.version.__version__ without
having to pull in the entire library
Added 'test' command for setup.py
Simplified testall.py
Docs build cleanly from source package after installation
Diffstat (limited to 'setup.py')
-rwxr-xr-x[-rw-r--r--] | setup.py | 21 |
1 files changed, 11 insertions, 10 deletions
@@ -4,16 +4,15 @@ # Copyright (C) 2007-2011 Nathanael C. Fritz # All Rights Reserved # -# This software is licensed as described in the README file, -# which you should have received as part of this distribution. -# +# This software is licensed as described in the README.rst and LICENSE +# file, which you should have received as part of this distribution. -# from ez_setup import use_setuptools -from distutils.core import setup import sys +from distutils.core import setup, Command +# from ez_setup import use_setuptools -import sleekxmpp - +from testall import TestCommand +from sleekxmpp.version import __version__ # if 'cygwin' in sys.platform.lower(): # min_version = '0.6c6' # else: @@ -27,10 +26,10 @@ import sleekxmpp # # from setuptools import setup, find_packages, Extension, Feature -VERSION = sleekxmpp.__version__ +VERSION = __version__ DESCRIPTION = 'SleekXMPP is an elegant Python library for XMPP (aka Jabber, Google Talk, etc).' with open('README.rst') as readme: - LONG_DESCRIPTION = '\n'.join(readme) + LONG_DESCRIPTION = ''.join(readme) CLASSIFIERS = [ 'Intended Audience :: Developers', 'License :: OSI Approved :: MIT License', @@ -93,5 +92,7 @@ setup( license = 'MIT', platforms = [ 'any' ], packages = packages, - requires = [ 'tlslite', 'pythondns' ], + requires = [ 'dnspython' ], + classifiers = CLASSIFIERS, + cmdclass = {'test': TestCommand} ) |