summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLance Stout <lancestout@gmail.com>2012-05-22 03:56:06 -0700
committerLance Stout <lancestout@gmail.com>2012-05-22 03:56:06 -0700
commitf49311ef9ee76c2e4cce402e377867eff308aca0 (patch)
tree50bb75037f13552d1c77ea23c1f46dcb69e7a3bf /setup.py
parent678e529efc0e6fff65133de6769a5596034d90c6 (diff)
downloadslixmpp-f49311ef9ee76c2e4cce402e377867eff308aca0.tar.gz
slixmpp-f49311ef9ee76c2e4cce402e377867eff308aca0.tar.bz2
slixmpp-f49311ef9ee76c2e4cce402e377867eff308aca0.tar.xz
slixmpp-f49311ef9ee76c2e4cce402e377867eff308aca0.zip
Add better certificate handling.
Certificate host names are now matched (using DNS, SRV, XMPPAddr, and Common Name), along with expiration check. Scheduled event to reset the stream once the server's cert expires. Handle invalid cert trust chains gracefully now.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4bb77bd9..de89021b 100755
--- a/setup.py
+++ b/setup.py
@@ -112,7 +112,7 @@ setup(
license = 'MIT',
platforms = [ 'any' ],
packages = packages,
- requires = [ 'dnspython' ],
+ requires = [ 'dnspython', 'pyasn1', 'pyasn1_modules' ],
classifiers = CLASSIFIERS,
cmdclass = {'test': TestCommand}
)