summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLance Stout <lancestout@gmail.com>2011-08-04 11:52:17 -0700
committerLance Stout <lancestout@gmail.com>2011-08-04 11:52:17 -0700
commit89cffd43f48cfc835b70e137776eb8c2e73a0b67 (patch)
tree088035aeb688edc6a0f5675de31eedf169f87fd3 /setup.py
parentad978700fc891602c826dea03615c396f39364a0 (diff)
parentb9764cc120c48576be1fe6cadb11813d12f91f4c (diff)
downloadslixmpp-89cffd43f48cfc835b70e137776eb8c2e73a0b67.tar.gz
slixmpp-89cffd43f48cfc835b70e137776eb8c2e73a0b67.tar.bz2
slixmpp-89cffd43f48cfc835b70e137776eb8c2e73a0b67.tar.xz
slixmpp-89cffd43f48cfc835b70e137776eb8c2e73a0b67.zip
Merge branch 'develop' into roster
Conflicts: setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 11 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 23baf8a3..db85f62d 100644
--- a/setup.py
+++ b/setup.py
@@ -45,8 +45,6 @@ packages = [ 'sleekxmpp',
'sleekxmpp/xmlstream',
'sleekxmpp/xmlstream/matcher',
'sleekxmpp/xmlstream/handler',
- 'sleekxmpp/thirdparty',
- 'sleekxmpp/roster',
'sleekxmpp/plugins',
'sleekxmpp/plugins/xep_0009',
'sleekxmpp/plugins/xep_0009/stanza',
@@ -54,11 +52,22 @@ packages = [ 'sleekxmpp',
'sleekxmpp/plugins/xep_0030/stanza',
'sleekxmpp/plugins/xep_0050',
'sleekxmpp/plugins/xep_0059',
+ 'sleekxmpp/plugins/xep_0060',
+ 'sleekxmpp/plugins/xep_0060/stanza',
'sleekxmpp/plugins/xep_0085',
'sleekxmpp/plugins/xep_0086',
'sleekxmpp/plugins/xep_0092',
'sleekxmpp/plugins/xep_0128',
'sleekxmpp/plugins/xep_0199',
+ 'sleekxmpp/features',
+ 'sleekxmpp/features/feature_mechanisms',
+ 'sleekxmpp/features/feature_mechanisms/stanza',
+ 'sleekxmpp/features/feature_starttls',
+ 'sleekxmpp/features/feature_bind',
+ 'sleekxmpp/features/feature_session',
+ 'sleekxmpp/thirdparty',
+ 'sleekxmpp/thirdparty/suelta',
+ 'sleekxmpp/thirdparty/suelta/mechanisms',
]
if sys.version_info < (3, 0):
@@ -80,4 +89,3 @@ setup(
py_modules = py_modules,
requires = [ 'tlslite', 'pythondns' ],
)
-