summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLance Stout <lancestout@gmail.com>2011-04-08 16:41:18 -0400
committerLance Stout <lancestout@gmail.com>2011-04-08 16:41:18 -0400
commit2e1befc8c6e3092b773a8c297bc183823c2eaeed (patch)
treedbb3ebac9ce5f1de8eea035f17bbc2b15edf8d0c /setup.py
parent87ccd804ff346f3c2aa06b2be9479b1f82817c12 (diff)
downloadslixmpp-2e1befc8c6e3092b773a8c297bc183823c2eaeed.tar.gz
slixmpp-2e1befc8c6e3092b773a8c297bc183823c2eaeed.tar.bz2
slixmpp-2e1befc8c6e3092b773a8c297bc183823c2eaeed.tar.xz
slixmpp-2e1befc8c6e3092b773a8c297bc183823c2eaeed.zip
Make setup.py use sleekxmpp.__version__
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 1443e90f..19047925 100644
--- a/setup.py
+++ b/setup.py
@@ -12,6 +12,8 @@
from distutils.core import setup
import sys
+import sleekxmpp
+
# if 'cygwin' in sys.platform.lower():
# min_version = '0.6c6'
# else:
@@ -25,7 +27,7 @@ import sys
#
# from setuptools import setup, find_packages, Extension, Feature
-VERSION = '1.0.0.0'
+VERSION = sleekxmpp.__version__
DESCRIPTION = 'SleekXMPP is an elegant Python library for XMPP (aka Jabber, Google Talk, etc).'
LONG_DESCRIPTION = """
SleekXMPP is an elegant Python library for XMPP (aka Jabber, Google Talk, etc).