summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLance Stout <lancestout@gmail.com>2012-01-09 15:38:19 -0800
committerLance Stout <lancestout@gmail.com>2012-01-09 15:38:19 -0800
commit1674bd753eb92b922627489a669ef57ef9853b44 (patch)
tree6941980de14a87f267ef73097a443190f148f43c /setup.py
parentc578ddeb1aae6fb0a9f60092b53831c1e952058d (diff)
downloadslixmpp-1674bd753eb92b922627489a669ef57ef9853b44.tar.gz
slixmpp-1674bd753eb92b922627489a669ef57ef9853b44.tar.bz2
slixmpp-1674bd753eb92b922627489a669ef57ef9853b44.tar.xz
slixmpp-1674bd753eb92b922627489a669ef57ef9853b44.zip
Fix setup.py Unicode issue with README.rst
Fixes issue #135
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index a49ec9d6..954a1022 100755
--- a/setup.py
+++ b/setup.py
@@ -8,6 +8,7 @@
# file, which you should have received as part of this distribution.
import sys
+import codecs
try:
from setuptools import setup, Command
except ImportError:
@@ -31,7 +32,7 @@ from sleekxmpp.version import __version__
VERSION = __version__
DESCRIPTION = 'SleekXMPP is an elegant Python library for XMPP (aka Jabber, Google Talk, etc).'
-with open('README.rst') as readme:
+with codecs.open('README.rst', 'r', encoding='UTF-8') as readme:
LONG_DESCRIPTION = ''.join(readme)
CLASSIFIERS = [ 'Intended Audience :: Developers',