diff options
author | Lance Stout <lancestout@gmail.com> | 2012-01-09 15:38:19 -0800 |
---|---|---|
committer | Lance Stout <lancestout@gmail.com> | 2012-01-09 15:38:19 -0800 |
commit | 1674bd753eb92b922627489a669ef57ef9853b44 (patch) | |
tree | 6941980de14a87f267ef73097a443190f148f43c /setup.py | |
parent | c578ddeb1aae6fb0a9f60092b53831c1e952058d (diff) | |
download | slixmpp-1674bd753eb92b922627489a669ef57ef9853b44.tar.gz slixmpp-1674bd753eb92b922627489a669ef57ef9853b44.tar.bz2 slixmpp-1674bd753eb92b922627489a669ef57ef9853b44.tar.xz slixmpp-1674bd753eb92b922627489a669ef57ef9853b44.zip |
Fix setup.py Unicode issue with README.rst
Fixes issue #135
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -8,6 +8,7 @@ # file, which you should have received as part of this distribution. import sys +import codecs try: from setuptools import setup, Command except ImportError: @@ -31,7 +32,7 @@ from sleekxmpp.version import __version__ VERSION = __version__ DESCRIPTION = 'SleekXMPP is an elegant Python library for XMPP (aka Jabber, Google Talk, etc).' -with open('README.rst') as readme: +with codecs.open('README.rst', 'r', encoding='UTF-8') as readme: LONG_DESCRIPTION = ''.join(readme) CLASSIFIERS = [ 'Intended Audience :: Developers', |