summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLance Stout <lancestout@gmail.com>2011-08-05 09:00:55 -0700
committerLance Stout <lancestout@gmail.com>2011-08-05 09:00:55 -0700
commit08cb5f42e7a37ac20928bbb6e62a35acc1de0f78 (patch)
tree8d57190de75cd4c8d25f4896de5e8aae0f87d63b /setup.py
parent9abf37bbd1e0e68397f0f55ace5eaba05c640720 (diff)
downloadslixmpp-08cb5f42e7a37ac20928bbb6e62a35acc1de0f78.tar.gz
slixmpp-08cb5f42e7a37ac20928bbb6e62a35acc1de0f78.tar.bz2
slixmpp-08cb5f42e7a37ac20928bbb6e62a35acc1de0f78.tar.xz
slixmpp-08cb5f42e7a37ac20928bbb6e62a35acc1de0f78.zip
Update the info in setup.py
I thought I had done this a long time ago, but it must have been in a lost branch. *shrug* It's too late for Beta6, so I've manually updated the PyPI entry.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py15
1 files changed, 9 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 3ccac3af..b997106c 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,7 @@
#!/usr/bin/env python
# -*- coding: utf-8 -*-
#
-# Copyright (C) 2007-2008 Nathanael C. Fritz
+# Copyright (C) 2007-2011 Nathanael C. Fritz
# All Rights Reserved
#
# This software is licensed as described in the README file,
@@ -29,13 +29,16 @@ import sleekxmpp
VERSION = sleekxmpp.__version__
DESCRIPTION = 'SleekXMPP is an elegant Python library for XMPP (aka Jabber, Google Talk, etc).'
-LONG_DESCRIPTION = """
-SleekXMPP is an elegant Python library for XMPP (aka Jabber, Google Talk, etc).
-"""
+with open('README') as readme:
+ LONG_DESCRIPTION = '\n'.join(readme)
CLASSIFIERS = [ 'Intended Audience :: Developers',
- 'License :: OSI Approved :: MIT',
+ 'License :: OSI Approved :: MIT License',
'Programming Language :: Python',
+ 'Programming Language :: Python 2.6',
+ 'Programming Language :: Python 2.7',
+ 'Programming Language :: Python 3.1',
+ 'Programming Language :: Python 3.2',
'Topic :: Software Development :: Libraries :: Python Modules',
]
@@ -82,7 +85,7 @@ setup(
long_description = LONG_DESCRIPTION,
author = 'Nathanael Fritz',
author_email = 'fritzy [at] netflint.net',
- url = 'http://code.google.com/p/sleekxmpp',
+ url = 'http://github.com/fritzy/SleekXMPP',
license = 'MIT',
platforms = [ 'any' ],
packages = packages,