summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLance Stout <lancestout@gmail.com>2010-08-05 20:26:41 -0400
committerLance Stout <lancestout@gmail.com>2010-08-05 20:26:41 -0400
commite077204a16c76df4af90ba067e94c31af3d9e372 (patch)
tree96d725f14af0f26f19241984a3d85d4555cf1111 /setup.py
parent58f77d898f82ab108fa17d562a32c68d3ea35306 (diff)
downloadslixmpp-e077204a16c76df4af90ba067e94c31af3d9e372.tar.gz
slixmpp-e077204a16c76df4af90ba067e94c31af3d9e372.tar.bz2
slixmpp-e077204a16c76df4af90ba067e94c31af3d9e372.tar.xz
slixmpp-e077204a16c76df4af90ba067e94c31af3d9e372.zip
Replaced the ToString class with a tostring function.
The sleekxmpp.xmlstream.tostring and sleekxmpp.xmlstream.tostring26 packages have been merged to sleekxmpp.xmlstream.tostring. The __init__.py file will import the appropriate tostring function depending on the Python version. The setup.py file has been updated with the package changes. ElementBase is now a direct descendent of object and does not subclass ToString. Stanza objects now return their XML contents for __repr__.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 5 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 280ec3c0..e3acf18a 100644
--- a/setup.py
+++ b/setup.py
@@ -16,13 +16,13 @@ import sys
# min_version = '0.6c6'
# else:
# min_version = '0.6a9'
-#
+#
# try:
# use_setuptools(min_version=min_version)
# except TypeError:
# # locally installed ez_setup won't have min_version
# use_setuptools()
-#
+#
# from setuptools import setup, find_packages, Extension, Feature
VERSION = '0.2.3.1'
@@ -37,17 +37,13 @@ CLASSIFIERS = [ 'Intended Audience :: Developers',
'Topic :: Software Development :: Libraries :: Python Modules',
]
-packages = [ 'sleekxmpp',
+packages = [ 'sleekxmpp',
'sleekxmpp/plugins',
'sleekxmpp/stanza',
'sleekxmpp/xmlstream',
'sleekxmpp/xmlstream/matcher',
- 'sleekxmpp/xmlstream/handler' ]
-
-if sys.version_info < (3, 0):
- packages.append('sleekxmpp/xmlstream/tostring26')
-else:
- packages.append('sleekxmpp/xmlstream/tostring')
+ 'sleekxmpp/xmlstream/handler',
+ 'sleekxmpp/xmlstream/tostring']
setup(
name = "sleekxmpp",