summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 16 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 00000000..50d787da
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,16 @@
+from distutils.core import setup, Extension
+
+module_poopt = Extension('poopt',
+ sources = ['src/pooptmodule.c'])
+
+setup (name = 'BuildLines',
+ version = '0.0.1',
+ description = 'Poezio Optimizations',
+ ext_modules = [module_poopt],
+ author = 'Florent Le Coz',
+ author_email = 'louiz@louiz.org',
+ long_description = """
+ a python3 module for poezio, used to replace some time-critical
+ python functions that are too slow. If compiled, poezio will use this module,
+ otherwise it will just use the equivalent python functions.
+ """)