summaryrefslogtreecommitdiff
path: root/tools/sticker-picker/Cargo.toml
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot <linkmauve@linkmauve.fr>2022-02-09 22:47:38 +0100
committerEmmanuel Gil Peyrot <linkmauve@linkmauve.fr>2022-02-10 01:45:37 +0100
commitd35c0564b3f5dd10f6e23bf462bbfabd3084e486 (patch)
tree4354ccef627717e05ea4cf8abea50ab1f105b58a /tools/sticker-picker/Cargo.toml
parent9735b6d6dc5ff6b5d577d2ba7511d74a9de99f38 (diff)
downloadpoezio-d35c0564b3f5dd10f6e23bf462bbfabd3084e486.tar.gz
poezio-d35c0564b3f5dd10f6e23bf462bbfabd3084e486.tar.bz2
poezio-d35c0564b3f5dd10f6e23bf462bbfabd3084e486.tar.xz
poezio-d35c0564b3f5dd10f6e23bf462bbfabd3084e486.zip
Add a /sticker plugin
This plugin currently uploads the selected sticker every time, to the HTTP File Upload service of the server (see XEP-0363), a future optimisation would be to use XEP-0231 instead, for better caching on the recipient side. It relies on a helper tool to select the wanted sticker inside the pack, a sample one is provided in tools/sticker-picker/, but it is not built by default.
Diffstat (limited to 'tools/sticker-picker/Cargo.toml')
-rw-r--r--tools/sticker-picker/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/tools/sticker-picker/Cargo.toml b/tools/sticker-picker/Cargo.toml
new file mode 100644
index 00000000..fdba8144
--- /dev/null
+++ b/tools/sticker-picker/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "poezio-sticker-picker"
+version = "0.1.0"
+edition = "2021"
+authors = ["Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>"]
+license = "Zlib"
+description = "Helper tool for selecting a sticker inside a pack"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+gtk = { package = "gtk4", version = "0.4", features = ["v4_6"] }
+gdk = { package = "gdk4", version = "0.4", features = ["v4_6"] }
+glib = "0.15"
+gio = "0.15"
+once_cell = "1.9.0"