summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot <linkmauve@linkmauve.fr>2018-08-20 21:38:45 +0100
committerEmmanuel Gil Peyrot <linkmauve@linkmauve.fr>2018-08-20 21:38:45 +0100
commitf2d2c4df3c48fc0ff04c1ce811e5f291500eb1f9 (patch)
tree17ea60793415d85db89ee36e36dc53683c2f1b1a /setup.py
parent7ce30f8f272227f1ef418c6bb5aafc7b9bde39e5 (diff)
downloadpoezio-f2d2c4df3c48fc0ff04c1ce811e5f291500eb1f9.tar.gz
poezio-f2d2c4df3c48fc0ff04c1ce811e5f291500eb1f9.tar.bz2
poezio-f2d2c4df3c48fc0ff04c1ce811e5f291500eb1f9.tar.xz
poezio-f2d2c4df3c48fc0ff04c1ce811e5f291500eb1f9.zip
Install the appdata file.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 079f4c5f..b9703af3 100755
--- a/setup.py
+++ b/setup.py
@@ -126,7 +126,8 @@ setup(name="poezio",
entry_points={'console_scripts': ['poezio = poezio.__main__:run']},
data_files=([('share/man/man1/', ['data/poezio.1',
'data/poezio_logs.1']),
- ('share/poezio/', ['README.rst', 'COPYING', 'CHANGELOG'])]
+ ('share/poezio/', ['README.rst', 'COPYING', 'CHANGELOG']),
+ ('share/metainfo/', ['data/io.poez.Poezio.appdata.xml'])]
+ find_doc('share/doc/poezio/source', 'source')
+ find_doc('share/doc/poezio/html', 'build/html')),
install_requires=['slixmpp>=1.3.0', 'aiodns', 'pyasn1_modules', 'pyasn1'],