summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authormathieui <mathieui@mathieui.net>2020-05-31 17:46:34 +0200
committermathieui <mathieui@mathieui.net>2020-05-31 17:50:19 +0200
commitd8785ae0bdc86d135043ecec39babc5c54106ef4 (patch)
tree0d3b2dfd36ec2f9b3ceb98fa56af59324283f19e /setup.py
parent7650591c6b921096ca270d626276e94479c271ab (diff)
downloadpoezio-d8785ae0bdc86d135043ecec39babc5c54106ef4.tar.gz
poezio-d8785ae0bdc86d135043ecec39babc5c54106ef4.tar.bz2
poezio-d8785ae0bdc86d135043ecec39babc5c54106ef4.tar.xz
poezio-d8785ae0bdc86d135043ecec39babc5c54106ef4.zip
Update version to 0.13.1v0.13.1
And remove some annoying logic
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 1e7dd8fc..a4714132 100755
--- a/setup.py
+++ b/setup.py
@@ -19,6 +19,8 @@ except ImportError:
current_dir = os.path.dirname(__file__)
+from poezio.version import __version__
+
def get_relative_dir(folder, stopper):
"""
Find the path from a directory to a pseudo-root in order to recreate
@@ -111,14 +113,14 @@ if os.path.exists(git_dir):
except:
version = '.dev1'
else:
- version = '.dev1'
+ version = ''
with open('README.rst', encoding='utf-8') as readme_fd:
LONG_DESCRIPTION = readme_fd.read()
setup(
name="poezio",
- version="0.14" + version,
+ version=__version__ + version,
description="A console XMPP client",
long_description=LONG_DESCRIPTION,
ext_modules=[module_poopt],