summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authormathieui <mathieui@mathieui.net>2015-01-21 14:18:19 +0100
committermathieui <mathieui@mathieui.net>2015-01-21 14:18:19 +0100
commit992a460cf6100f5b851c85190352f1d810c6d3ff (patch)
tree906656933d74b2f33c54835460094d3c1e84b036 /setup.py
parenteb79322945c596d6c66c75b51fd5c9b3fe00f5a4 (diff)
downloadpoezio-992a460cf6100f5b851c85190352f1d810c6d3ff.tar.gz
poezio-992a460cf6100f5b851c85190352f1d810c6d3ff.tar.bz2
poezio-992a460cf6100f5b851c85190352f1d810c6d3ff.tar.xz
poezio-992a460cf6100f5b851c85190352f1d810c6d3ff.zip
Ignore stderr when doing the git revision check
(and use the older --git-dir instead of -C)
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index d947bc58..1b517838 100755
--- a/setup.py
+++ b/setup.py
@@ -29,8 +29,9 @@ git_dir = os.path.join(current_dir, '.git')
if os.path.exists(git_dir):
try:
import subprocess
- result = subprocess.Popen(['git', '-C', git_dir, 'describe'],
+ result = subprocess.Popen(['git', '--git-dir', git_dir, 'describe'],
stdout=subprocess.PIPE)
+ stderr=subprocess.DEVNULL)
result.wait()
data = result.stdout.read().decode('utf-8', errors='ignore')
version = '.dev' + data.split('-')[1]