summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJonas Schäfer <j.wielicki@sotecware.net>2018-10-01 17:30:25 +0200
committerJonas Schäfer <j.wielicki@sotecware.net>2018-10-15 19:56:22 +0200
commitd85ad57f1e7a2338e20176a4450732a3d52f2747 (patch)
tree774975a2130765a3f1e80d04a4f66ed634245a7a /setup.py
parent1ed666c5b541eb7e1a294681790e09eac8cc0f5d (diff)
downloadpoezio-d85ad57f1e7a2338e20176a4450732a3d52f2747.tar.gz
poezio-d85ad57f1e7a2338e20176a4450732a3d52f2747.tar.bz2
poezio-d85ad57f1e7a2338e20176a4450732a3d52f2747.tar.xz
poezio-d85ad57f1e7a2338e20176a4450732a3d52f2747.zip
from __future__ import xep_0392.v0_5
Ahem. Thes updates poezio to use the HSLuv colour space to generate colours according to XEP-0392. This will become the standard in XEP-0392 v0.5.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 24eb26f8..574879d1 100755
--- a/setup.py
+++ b/setup.py
@@ -131,7 +131,7 @@ setup(name="poezio",
('share/metainfo/', ['data/io.poez.Poezio.appdata.xml'])]
+ find_doc('share/doc/poezio/source', 'source')
+ find_doc('share/doc/poezio/html', 'build/html')),
- install_requires=['slixmpp>=1.3.0', 'aiodns', 'pyasn1_modules', 'pyasn1'],
+ install_requires=['slixmpp>=1.3.0', 'aiodns', 'pyasn1_modules', 'pyasn1', 'hsluv~=0.0.2'],
extras_require={'OTR plugin': 'python-potr>=1.0',
'Screen autoaway plugin': 'pyinotify==0.9.4',
'Avoiding cython': 'cffi'})