summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authormathieui <mathieui@mathieui.net>2014-10-27 19:16:32 +0100
committermathieui <mathieui@mathieui.net>2014-10-27 19:16:32 +0100
commitf55ac9edbfbfeb13e93cb101df8d38bd7bcce15a (patch)
treee3eb51f11f9138cbf9807387ca42fd2e84b59a6f /setup.py
parent22f9b7a66ab4a3f5d3927e429912237df2a3aa15 (diff)
downloadpoezio-f55ac9edbfbfeb13e93cb101df8d38bd7bcce15a.tar.gz
poezio-f55ac9edbfbfeb13e93cb101df8d38bd7bcce15a.tar.bz2
poezio-f55ac9edbfbfeb13e93cb101df8d38bd7bcce15a.tar.xz
poezio-f55ac9edbfbfeb13e93cb101df8d38bd7bcce15a.zip
Mention that setuptools is kind of mandatory
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 6 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 6c70c208..efd914b0 100755
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,13 @@
#!/usr/bin/env python3
+
try:
from setuptools import setup, Extension
except ImportError:
+ print('Setuptools was not found.\n'
+ 'This script will use distutils instead, which will NOT'
+ ' be able to install a `poezio` executable.\nIf you are '
+ 'using it to build a package or install poezio, please '
+ 'install setuptools.\n\nYou will also see a few warnings.\n')
from distutils.core import setup, Extension
import os