summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authormathieui <mathieui@mathieui.net>2015-02-07 22:09:05 +0100
committermathieui <mathieui@mathieui.net>2015-02-07 22:09:05 +0100
commit556fd35cf5c60842d2a3b2e29e3ef5c9edbe35a2 (patch)
treef2da8490e9e522a3646ee2a0951f389c51a97aef /setup.py
parent61f28d7ffeae0b6a8fd8ca0617e082e2196df622 (diff)
downloadpoezio-556fd35cf5c60842d2a3b2e29e3ef5c9edbe35a2.tar.gz
poezio-556fd35cf5c60842d2a3b2e29e3ef5c9edbe35a2.tar.bz2
poezio-556fd35cf5c60842d2a3b2e29e3ef5c9edbe35a2.tar.xz
poezio-556fd35cf5c60842d2a3b2e29e3ef5c9edbe35a2.zip
Entirely ditch distutils for setuptools
(it wasn’t working anyways, except for building the poopt module)
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py9
1 files changed, 3 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index b5a97fb2..97ae2a53 100755
--- a/setup.py
+++ b/setup.py
@@ -3,12 +3,9 @@
try:
from setuptools import setup, Extension
except ImportError:
- print('Setuptools was not found.\n'
- 'This script will use distutils instead, which will NOT'
- ' be able to install a `poezio` executable.\nIf you are '
- 'using it to build a package or install poezio, please '
- 'install setuptools.\n\nYou will also see a few warnings.\n')
- from distutils.core import setup, Extension
+ print('\nSetuptools was not found. Install setuptools for python 3.\n')
+ import sys
+ sys.exit(1)
import os