summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authormathieui <mathieui@mathieui.net>2013-05-29 15:32:25 +0200
committermathieui <mathieui@mathieui.net>2013-05-29 15:32:25 +0200
commit4ee7708b1403088355c6f876a95cab65cc7d9296 (patch)
tree34d63716b28eb03c9a66f3b046b5b789d47cbbce /setup.py
parent2641996468dee89fff5adb5a55ebeae0e2cd57c0 (diff)
downloadpoezio-4ee7708b1403088355c6f876a95cab65cc7d9296.tar.gz
poezio-4ee7708b1403088355c6f876a95cab65cc7d9296.tar.bz2
poezio-4ee7708b1403088355c6f876a95cab65cc7d9296.tar.xz
poezio-4ee7708b1403088355c6f876a95cab65cc7d9296.zip
Small workaround for the default config location
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 18 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index b223b5e3..675078a1 100644
--- a/setup.py
+++ b/setup.py
@@ -1,14 +1,23 @@
from distutils.core import setup, Extension
+import os, sys
module_poopt = Extension('poezio.poopt',
sources = ['src/pooptmodule.c'])
+
+current_dir = os.path.dirname(__file__)
+
+# Create a link to the config file (for packaging purposes)
+if not os.path.exists(os.path.join(current_dir, 'src', 'default_config.cfg')):
+ os.link(os.path.join(current_dir, 'data', 'default_config.cfg'),
+ os.path.join(current_dir, 'src', 'default_config.cfg'))
+
setup(name="poezio",
version="0.8-dev",
description="A console XMPP client",
long_description=
"""
- Poezio is a free chat client aiming to reproduce the ease of use of most
+ Poezio is a Free chat client aiming to reproduce the ease of use of most
IRC clients (e.g. weechat, irssi) while using the XMPP network.
""",
ext_modules = [module_poopt],
@@ -30,11 +39,16 @@ setup(name="poezio",
'Topic :: Communications :: Chat',
'Programming Language :: Python :: 3',
],
- keywords = ['xmpp', 'chat', 'im', 'console'],
+ keywords = ['jabber', 'xmpp', 'client', 'chat', 'im', 'console'],
packages = ['poezio', 'poezio_plugins'],
package_dir = {'poezio': 'src', 'poezio_plugins': 'plugins'},
+ package_data = {'poezio': ['default_config.cfg']},
scripts = ['scripts/poezio'],
- data_files = [('/etc/poezio/', ['data/default_config.cfg']),
- ('share/poezio/themes/', ['data/themes/dark.py']),
+ data_files = [('share/poezio/themes/', ['data/themes/dark.py']),
('share/man/man1/', ['data/poezio.1'])],
)
+
+# Remove the link afterwards
+if os.path.exists(os.path.join(current_dir, 'src', 'default_config.cfg')):
+ os.unlink(os.path.join(current_dir, 'src', 'default_config.cfg'))
+