summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMaxime “pep” Buquet <pep@bouah.net>2022-03-14 22:59:49 +0100
committerMaxime “pep” Buquet <pep@bouah.net>2022-08-21 17:19:58 +0200
commit8600e053e447091a16862aa91a58ba216a052c38 (patch)
tree8476c8f7d05353e7c308b03855a881b1e919a805 /setup.py
parenteef1d2041d9c6d213cc41640d57805cca6f1d3ef (diff)
downloadpoezio-8600e053e447091a16862aa91a58ba216a052c38.tar.gz
poezio-8600e053e447091a16862aa91a58ba216a052c38.tar.bz2
poezio-8600e053e447091a16862aa91a58ba216a052c38.tar.xz
poezio-8600e053e447091a16862aa91a58ba216a052c38.zip
Move to PyO3
Signed-off-by: Maxime “pep” Buquet <pep@bouah.net>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4c568c38..54f082d9 100755
--- a/setup.py
+++ b/setup.py
@@ -130,7 +130,7 @@ setup(
description="A console XMPP client",
long_description=LONG_DESCRIPTION,
ext_modules=[module_poopt],
- rust_extensions=[RustExtension('poezio.libpoezio', binding=Binding.RustCPython)],
+ rust_extensions=[RustExtension('poezio.libpoezio', binding=Binding.PyO3)],
url='https://poez.io/',
license='GPL-3.0-or-later',
download_url='https://dev.louiz.org/projects/poezio/files',