summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2011-09-09 18:46:42 +0200
committerFlorent Le Coz <louiz@louiz.org>2011-09-09 18:46:42 +0200
commitd26845e2a3896755a04a2c338cb2ebb6c9fcc0de (patch)
tree4f3760242a10baba3cb9425cb764b03a8c2d5793 /setup.py
parentfa5b5fc45dfb6e3a736954f0a916541fda963305 (diff)
downloadpoezio-d26845e2a3896755a04a2c338cb2ebb6c9fcc0de.tar.gz
poezio-d26845e2a3896755a04a2c338cb2ebb6c9fcc0de.tar.bz2
poezio-d26845e2a3896755a04a2c338cb2ebb6c9fcc0de.tar.xz
poezio-d26845e2a3896755a04a2c338cb2ebb6c9fcc0de.zip
and that fileā€¦
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 16 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 00000000..50d787da
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,16 @@
+from distutils.core import setup, Extension
+
+module_poopt = Extension('poopt',
+ sources = ['src/pooptmodule.c'])
+
+setup (name = 'BuildLines',
+ version = '0.0.1',
+ description = 'Poezio Optimizations',
+ ext_modules = [module_poopt],
+ author = 'Florent Le Coz',
+ author_email = 'louiz@louiz.org',
+ long_description = """
+ a python3 module for poezio, used to replace some time-critical
+ python functions that are too slow. If compiled, poezio will use this module,
+ otherwise it will just use the equivalent python functions.
+ """)