summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authormathieui <mathieui@mathieui.net>2013-08-10 00:24:27 +0200
committermathieui <mathieui@mathieui.net>2013-08-10 00:24:27 +0200
commit64c1a09023298e75eed0b2a0e736d1422f7f46b7 (patch)
tree618030ef3fc30754aef7e054e2eb400e4c3c3780 /setup.py
parenta50b32896d6d6f9ee9786575da65f2ea32b047de (diff)
downloadpoezio-64c1a09023298e75eed0b2a0e736d1422f7f46b7.tar.gz
poezio-64c1a09023298e75eed0b2a0e736d1422f7f46b7.tar.bz2
poezio-64c1a09023298e75eed0b2a0e736d1422f7f46b7.tar.xz
poezio-64c1a09023298e75eed0b2a0e736d1422f7f46b7.zip
Fix #2337 (search the themes the same way than plugins)
- Load the themes from: 1 - The sources found in the directory ../data/themes/ (if it exists) 2 - The user-defined dir (or ~/.local/blah) 3 - The poezio_themes package if found - Also fix some potential issues with the plugins importer
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index e57f9a70..a07b74c9 100644
--- a/setup.py
+++ b/setup.py
@@ -40,8 +40,8 @@ setup(name="poezio",
'Programming Language :: Python :: 3',
],
keywords = ['jabber', 'xmpp', 'client', 'chat', 'im', 'console'],
- packages = ['poezio', 'poezio_plugins', 'poezio_plugins.gpg'],
- package_dir = {'poezio': 'src', 'poezio_plugins': 'plugins'},
+ packages = ['poezio', 'poezio_plugins', 'poezio_plugins.gpg', 'poezio_themes'],
+ package_dir = {'poezio': 'src', 'poezio_plugins': 'plugins', 'poezio_themes': 'data/themes'},
package_data = {'poezio': ['default_config.cfg']},
scripts = ['scripts/poezio'],
data_files = [('share/poezio/themes/', ['data/themes/dark.py']),