summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authormathieui <mathieui@mathieui.net>2017-10-10 00:52:44 +0200
committermathieui <mathieui@mathieui.net>2017-10-10 00:52:44 +0200
commitef84a109e8f492c83979443b6366fb8ca4028009 (patch)
tree199acf4a299122f3a0a39bb94f810fdf293020b0 /setup.py
parentdcdc970acd64d1c3925a2c8c5690b58e209e001c (diff)
downloadpoezio-ef84a109e8f492c83979443b6366fb8ca4028009.tar.gz
poezio-ef84a109e8f492c83979443b6366fb8ca4028009.tar.bz2
poezio-ef84a109e8f492c83979443b6366fb8ca4028009.tar.xz
poezio-ef84a109e8f492c83979443b6366fb8ca4028009.zip
Fix #3190 (TOFU the SPKI hash and not the whole cert)
Makes letsencrypt renewals more pleasant. Thanks jonasw and aioxmpp for the ASN.1 wizardry
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8aea5a6f..49677d87 100755
--- a/setup.py
+++ b/setup.py
@@ -106,7 +106,7 @@ setup(name="poezio",
('share/poezio/', ['README.rst', 'COPYING', 'CHANGELOG'])]
+ find_doc('share/doc/poezio/source', 'source')
+ find_doc('share/doc/poezio/html', 'build/html')),
- install_requires=['slixmpp>=1.2.4', 'aiodns'],
+ install_requires=['slixmpp>=1.2.4', 'aiodns', 'pyasn1', 'pyasn1_modules'],
extras_require={'OTR plugin': 'python-potr>=1.0',
'Screen autoaway plugin': 'pyinotify==0.9.4'})