summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authormathieui <mathieui@mathieui.net>2015-01-21 00:29:08 +0100
committermathieui <mathieui@mathieui.net>2015-01-21 00:29:08 +0100
commiteb79322945c596d6c66c75b51fd5c9b3fe00f5a4 (patch)
tree9f6136e296d9c4e49289a8bb5f9c7d41d510aa01 /setup.py
parentef3f5bf1d171c031578e8eb5219d404a6dd8d4fc (diff)
downloadpoezio-eb79322945c596d6c66c75b51fd5c9b3fe00f5a4.tar.gz
poezio-eb79322945c596d6c66c75b51fd5c9b3fe00f5a4.tar.bz2
poezio-eb79322945c596d6c66c75b51fd5c9b3fe00f5a4.tar.xz
poezio-eb79322945c596d6c66c75b51fd5c9b3fe00f5a4.zip
Update the setup.py to 0.9 and use PEP 440 for development builds
detect the number of git commit since the last tag and use that
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py20
1 files changed, 17 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index eaa0b253..d947bc58 100755
--- a/setup.py
+++ b/setup.py
@@ -24,15 +24,29 @@ if not os.path.exists(os.path.join(current_dir, 'src', 'default_config.cfg')):
os.link(os.path.join(current_dir, 'data', 'default_config.cfg'),
os.path.join(current_dir, 'src', 'default_config.cfg'))
+# identify the git version
+git_dir = os.path.join(current_dir, '.git')
+if os.path.exists(git_dir):
+ try:
+ import subprocess
+ result = subprocess.Popen(['git', '-C', git_dir, 'describe'],
+ stdout=subprocess.PIPE)
+ result.wait()
+ data = result.stdout.read().decode('utf-8', errors='ignore')
+ version = '.dev' + data.split('-')[1]
+ except:
+ version = '.dev1'
+else:
+ version = '.dev1'
+
setup(name="poezio",
- version="0.8.3-dev",
+ version="0.9" + version,
description="A console XMPP client",
long_description=
"Poezio is a Free chat client aiming to reproduce the ease of use of most "
"IRC clients (e.g. weechat, irssi) while using the XMPP network."
"\n"
- "Documentation is available at http://doc.poez.io/0.8.",
-
+ "Documentation is available at http://doc.poez.io/.",
ext_modules = [module_poopt],
url = 'http://poez.io/',