summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authormathieui <mathieui@mathieui.net>2017-11-15 00:44:26 +0100
committermathieui <mathieui@mathieui.net>2017-11-15 20:50:42 +0100
commit659b310eed9e665d0f13d18d078848cae5acd2f6 (patch)
treea9b01502abbc5f472563a39aa8453e28dbce57e7 /setup.py
parent156d170d13dd3268728767adf9147e8c4d53d01f (diff)
downloadpoezio-659b310eed9e665d0f13d18d078848cae5acd2f6.tar.gz
poezio-659b310eed9e665d0f13d18d078848cae5acd2f6.tar.bz2
poezio-659b310eed9e665d0f13d18d078848cae5acd2f6.tar.xz
poezio-659b310eed9e665d0f13d18d078848cae5acd2f6.zip
Update gitlab-ci yaml
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 49677d87..7d73e4f3 100755
--- a/setup.py
+++ b/setup.py
@@ -106,9 +106,10 @@ setup(name="poezio",
('share/poezio/', ['README.rst', 'COPYING', 'CHANGELOG'])]
+ find_doc('share/doc/poezio/source', 'source')
+ find_doc('share/doc/poezio/html', 'build/html')),
- install_requires=['slixmpp>=1.2.4', 'aiodns', 'pyasn1', 'pyasn1_modules'],
+ install_requires=['slixmpp>=1.2.4', 'aiodns', 'pyasn1_modules', 'pyasn1'],
extras_require={'OTR plugin': 'python-potr>=1.0',
- 'Screen autoaway plugin': 'pyinotify==0.9.4'})
+ 'Screen autoaway plugin': 'pyinotify==0.9.4',
+ 'Avoiding cython': 'cffi'})
# Remove the link afterwards
if (exists(join(current_dir, 'poezio', 'default_config.cfg')) and