summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authormathieui <mathieui@mathieui.net>2016-07-03 01:59:05 +0200
committermathieui <mathieui@mathieui.net>2016-07-03 01:59:05 +0200
commit401048aba1b6e4cb0b5bf28e2319c89593253cc3 (patch)
tree8dfce3850f40f8bf6e30bc0fb67f7eef133e2546 /setup.py
parent8f1f877c967ee0a080bdecdcf14a400d52bdc475 (diff)
downloadpoezio-401048aba1b6e4cb0b5bf28e2319c89593253cc3.tar.gz
poezio-401048aba1b6e4cb0b5bf28e2319c89593253cc3.tar.bz2
poezio-401048aba1b6e4cb0b5bf28e2319c89593253cc3.tar.xz
poezio-401048aba1b6e4cb0b5bf28e2319c89593253cc3.zip
Make the entry point a function
otherwise it breaks the generated entry point loader, which will work but display a traceback on exit
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c421ff0f..fbd211a5 100755
--- a/setup.py
+++ b/setup.py
@@ -96,7 +96,7 @@ setup(name="poezio",
'poezio_themes': 'data/themes'},
package_data={'poezio': ['default_config.cfg']},
scripts=['scripts/poezio_gpg_export'],
- entry_points={'console_scripts': ['poezio = poezio.__main__']},
+ entry_points={'console_scripts': ['poezio = poezio.__main__:run']},
data_files=([('share/man/man1/', ['data/poezio.1']),
('share/poezio/', ['README.rst', 'COPYING', 'CHANGELOG'])]
+ find_doc('share/doc/poezio/source', 'source')