summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMaxime “pep” Buquet <pep@bouah.net>2022-08-21 22:53:40 +0200
committerMaxime “pep” Buquet <pep@bouah.net>2022-08-23 11:44:11 +0200
commit10cc67e6c78ca37508ba30cba42baa68c8fff5a3 (patch)
tree35a040ed084f389937675218341ff7d2319315d4 /Cargo.toml
parentc68b00ae248476751935499dbe5fb151e2919569 (diff)
downloadpoezio-10cc67e6c78ca37508ba30cba42baa68c8fff5a3.tar.gz
poezio-10cc67e6c78ca37508ba30cba42baa68c8fff5a3.tar.bz2
poezio-10cc67e6c78ca37508ba30cba42baa68c8fff5a3.tar.xz
poezio-10cc67e6c78ca37508ba30cba42baa68c8fff5a3.zip
roezio: migrate poezio/args.py
Signed-off-by: Maxime “pep” Buquet <pep@bouah.net>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 89c2c548..bd86bf6b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,7 +5,9 @@ edition = "2021"
authors = [
"Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>",
"Maxime “pep” Buquet <pep@bouah.net>",
+ "Mathieu Pasquet <mathieui@mathieui.net>",
]
+description = "A console XMPP client"
[dependencies]
pyo3 = { version = "0.16", features = ["extension-module"] }
@@ -14,6 +16,7 @@ chrono = "0.4"
ncurses = "5"
lazy_static = "1"
enum-set = "0.0"
+clap = { version = "3.2.17", features = ["derive"] }
[lib]
crate-type = ["cdylib"]