summaryrefslogtreecommitdiff
path: root/docker/biboumi-test
diff options
context:
space:
mode:
Diffstat (limited to 'docker/biboumi-test')
-rw-r--r--docker/biboumi-test/alpine/Dockerfile3
-rw-r--r--docker/biboumi-test/archlinux/Dockerfile13
-rw-r--r--docker/biboumi-test/debian/Dockerfile5
-rw-r--r--docker/biboumi-test/fedora/Dockerfile1
4 files changed, 6 insertions, 16 deletions
diff --git a/docker/biboumi-test/alpine/Dockerfile b/docker/biboumi-test/alpine/Dockerfile
index f97c58c..e43f1b6 100644
--- a/docker/biboumi-test/alpine/Dockerfile
+++ b/docker/biboumi-test/alpine/Dockerfile
@@ -32,7 +32,8 @@ RUN apk add --no-cache g++\
openssl\
libressl-dev\
zlib-dev\
- curl
+ curl\
+ postgresql-dev
# Install botan
RUN git clone https://github.com/randombit/botan.git && cd botan && ./configure.py --prefix=/usr && make -j8 && make install && rm -rf /botan
diff --git a/docker/biboumi-test/archlinux/Dockerfile b/docker/biboumi-test/archlinux/Dockerfile
deleted file mode 100644
index 20f0343..0000000
--- a/docker/biboumi-test/archlinux/Dockerfile
+++ /dev/null
@@ -1,13 +0,0 @@
-FROM docker.io/base/archlinux:latest
-
-RUN pacman -Syuuuu --noconfirm
-
-RUN pacman -Syu --noconfirm cmake base-devel git clang-tools-extra
-
-RUN useradd -m -G wheel -s /bin/bash builder
-
-RUN sed -i '/^# %wheel ALL=(ALL) NOPASSWD: ALL/s/^# //' /etc/sudoers
-
-WORKDIR /home/builder
-
-USER builder
diff --git a/docker/biboumi-test/debian/Dockerfile b/docker/biboumi-test/debian/Dockerfile
index 3a1c1a7..557face 100644
--- a/docker/biboumi-test/debian/Dockerfile
+++ b/docker/biboumi-test/debian/Dockerfile
@@ -39,13 +39,14 @@ RUN apt install -y g++\
openssl\
zlib1g-dev\
libssl-dev\
- curl
+ curl\
+ libpq-dev
# Install botan
RUN git clone https://github.com/randombit/botan.git && cd botan && ./configure.py --prefix=/usr && make -j8 && make install && rm -rf /botan
# Install slixmpp, for e2e tests
-RUN git clone https://github.com/saghul/aiodns.git && cd aiodns && git checkout 7ee13f9bea25784322~ && python3 setup.py build && python3 setup.py install && git clone git://git.louiz.org/slixmpp && pip3 install pyasn1 && cd slixmpp && python3 setup.py build && python3 setup.py install
+RUN git clone https://github.com/saghul/aiodns.git && cd aiodns && git checkout 7ee13f9bea25784322~ && python3 setup.py build && python3 setup.py install && git clone git://git.louiz.org/slixmpp && pip3 install pyasn1==0.4.2 && cd slixmpp && python3 setup.py build && python3 setup.py install
RUN useradd tester -m
diff --git a/docker/biboumi-test/fedora/Dockerfile b/docker/biboumi-test/fedora/Dockerfile
index 8ff418c..12e13e5 100644
--- a/docker/biboumi-test/fedora/Dockerfile
+++ b/docker/biboumi-test/fedora/Dockerfile
@@ -39,6 +39,7 @@ RUN dnf --refresh install -y\
openssl-devel\
which\
java-1.8.0-openjdk\
+ postgresql-devel\
&& dnf clean all
# Install botan