summaryrefslogtreecommitdiff
path: root/docker/biboumi-test
diff options
context:
space:
mode:
Diffstat (limited to 'docker/biboumi-test')
-rw-r--r--docker/biboumi-test/alpine/Dockerfile10
-rw-r--r--docker/biboumi-test/alpine/Dockerfile.base51
-rw-r--r--docker/biboumi-test/archlinux/Dockerfile13
-rw-r--r--docker/biboumi-test/debian/Dockerfile.base1
-rw-r--r--docker/biboumi-test/fedora/Dockerfile.base2
5 files changed, 76 insertions, 1 deletions
diff --git a/docker/biboumi-test/alpine/Dockerfile b/docker/biboumi-test/alpine/Dockerfile
new file mode 100644
index 0000000..ab288b6
--- /dev/null
+++ b/docker/biboumi-test/alpine/Dockerfile
@@ -0,0 +1,10 @@
+# This Dockerfile creates a docker image suitable to run biboumi’s build and
+# tests. For example, it can be used on with gitlab-ci.
+
+FROM docker.louiz.org/biboumi-test-alpine-base
+
+# Install litesql
+RUN git clone git://git.louiz.org/litesql && mkdir /litesql/build && cd /litesql/build && cmake .. -DCMAKE_INSTALL_PREFIX=/usr && make -j8 && cd /litesql/build && make install && rm -rf /litesql && ldconfig || true
+
+WORKDIR /home/tester
+USER tester
diff --git a/docker/biboumi-test/alpine/Dockerfile.base b/docker/biboumi-test/alpine/Dockerfile.base
new file mode 100644
index 0000000..dffa1d1
--- /dev/null
+++ b/docker/biboumi-test/alpine/Dockerfile.base
@@ -0,0 +1,51 @@
+# This Dockerfile creates a docker image suitable to run biboumi’s build and
+# tests. For example, it can be used on with gitlab-ci.
+
+FROM docker.io/alpine:latest
+
+ENV LC_ALL C.UTF-8
+
+# Needed to build biboumi
+RUN apk add --no-cache g++\
+ clang\
+ valgrind\
+ udns-dev\
+ c-ares-dev\
+ sqlite-dev\
+ libuuid\
+ util-linux-dev\
+ libgcrypt-dev\
+ cmake\
+ make\
+ expat-dev\
+ libidn-dev\
+ git\
+ py3-lxml\
+ libtool\
+ py3-pip\
+ python2\
+ python3-dev\
+ automake\
+ autoconf\
+ flex\
+ bison\
+ libltdl\
+ openssl\
+ libressl-dev\
+ zlib-dev\
+ curl
+
+# Install botan
+RUN git clone https://github.com/randombit/botan.git && cd botan && ./configure.py --prefix=/usr && make -j8 && make install && rm -rf /botan
+
+# Install slixmpp, for e2e tests
+RUN git clone https://github.com/saghul/aiodns.git && cd aiodns && git checkout 7ee13f9bea25784322~ && python3 setup.py build && python3 setup.py install && git clone git://git.louiz.org/slixmpp && pip3 install pyasn1 && cd slixmpp && python3 setup.py build && python3 setup.py install
+
+RUN adduser tester -D -h /home/tester
+
+# Install charybdis, for e2e tests
+RUN git clone https://github.com/charybdis-ircd/charybdis.git && cd charybdis && cd /charybdis && git checkout 4f2b9a4 && sed s/113/1113/ -i /charybdis/authd/providers/ident.c && ./autogen.sh && ./configure --prefix=/home/tester/ircd --bindir=/usr/bin && make -j8 && make install && rm -rf /charybdis
+
+RUN chown -R tester:tester /home/tester/ircd
+
+RUN yes "" | openssl req -nodes -x509 -newkey rsa:4096 -keyout /home/tester/ircd/etc/ssl.key -out /home/tester/ircd/etc/ssl.pem
diff --git a/docker/biboumi-test/archlinux/Dockerfile b/docker/biboumi-test/archlinux/Dockerfile
new file mode 100644
index 0000000..20f0343
--- /dev/null
+++ b/docker/biboumi-test/archlinux/Dockerfile
@@ -0,0 +1,13 @@
+FROM docker.io/base/archlinux:latest
+
+RUN pacman -Syuuuu --noconfirm
+
+RUN pacman -Syu --noconfirm cmake base-devel git clang-tools-extra
+
+RUN useradd -m -G wheel -s /bin/bash builder
+
+RUN sed -i '/^# %wheel ALL=(ALL) NOPASSWD: ALL/s/^# //' /etc/sudoers
+
+WORKDIR /home/builder
+
+USER builder
diff --git a/docker/biboumi-test/debian/Dockerfile.base b/docker/biboumi-test/debian/Dockerfile.base
index e609feb..f5d061b 100644
--- a/docker/biboumi-test/debian/Dockerfile.base
+++ b/docker/biboumi-test/debian/Dockerfile.base
@@ -12,6 +12,7 @@ RUN apt install -y g++\
clang\
valgrind\
libudns-dev\
+ libc-ares-dev\
libsqlite3-dev\
libuuid1\
libgcrypt20-dev\
diff --git a/docker/biboumi-test/fedora/Dockerfile.base b/docker/biboumi-test/fedora/Dockerfile.base
index dd536e5..20984a2 100644
--- a/docker/biboumi-test/fedora/Dockerfile.base
+++ b/docker/biboumi-test/fedora/Dockerfile.base
@@ -10,6 +10,7 @@ RUN dnf --refresh install -y\
clang\
valgrind\
udns-devel\
+ c-ares-devel\
sqlite-devel\
libuuid-devel\
libgcrypt-devel\
@@ -56,4 +57,3 @@ RUN chown -R tester:tester /home/tester/ircd
RUN yes "" | openssl req -nodes -x509 -newkey rsa:4096 -keyout /home/tester/ircd/etc/ssl.key -out /home/tester/ircd/etc/ssl.pem
COPY coverity /home/tester/coverity
-COPY sonar-scanner-2.8 /home/tester/sonar-scanner