summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index c80ba2e..071b025 100755
--- a/debian/rules
+++ b/debian/rules
@@ -28,6 +28,10 @@ dev-deps = expat1 idn11 systemd c-ares botan1.10
CDBS_BUILD_DEPENDS += , cmake, catch, uuid-dev, pandoc
CDBS_BUILD_DEPENDS += , $(patsubst %,$(comma) lib%-dev,$(dev-deps))
+DEB_CMAKE_EXTRA_FLAGS = \
+ -DBOTAN_LIBRARIES="$(shell pkg-config botan-1.10 --libs-only-L)" \
+ -DBOTAN_INCLUDE_DIRS="$(shell pkg-config botan-1.10 --cflags-only-I)"
+
DEB_MAKE_CHECK_TARGET = check
DEB_INSTALL_CHANGELOGS_ALL += CHANGELOG.rst