summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/2001_cmake_ignore_git.patch40
-rw-r--r--debian/patches/2002_fix_default_locale.patch16
-rw-r--r--debian/patches/README3
-rw-r--r--debian/patches/series2
4 files changed, 61 insertions, 0 deletions
diff --git a/debian/patches/2001_cmake_ignore_git.patch b/debian/patches/2001_cmake_ignore_git.patch
new file mode 100644
index 0000000..4334d0f
--- /dev/null
+++ b/debian/patches/2001_cmake_ignore_git.patch
@@ -0,0 +1,40 @@
+Description: Avoid cmake messing with git
+Author: Jonas Smedegaard <dr@jones.dk>
+Last-Update: 2016-12-21
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -198,23 +198,6 @@
+ database)
+ endif()
+
+-include(ExternalProject)
+-ExternalProject_Add(catch
+- GIT_REPOSITORY "https://lab.louiz.org/louiz/Catch.git"
+- PREFIX "external"
+- UPDATE_COMMAND ""
+- CONFIGURE_COMMAND ""
+- BUILD_COMMAND ""
+- INSTALL_COMMAND ""
+- )
+-set_target_properties(catch PROPERTIES EXCLUDE_FROM_ALL TRUE)
+-ExternalProject_Get_Property(catch SOURCE_DIR)
+-if(NOT EXISTS ${CMAKE_SOURCE_DIR}/tests/catch.hpp)
+- target_include_directories(test_suite
+- PUBLIC "${SOURCE_DIR}/include/"
+- )
+- add_dependencies(test_suite catch)
+-endif()
+ add_custom_target(check COMMAND "test_suite"
+ DEPENDS test_suite biboumi)
+ add_custom_target(e2e COMMAND "python3" "${CMAKE_CURRENT_SOURCE_DIR}/tests/end_to_end/"
+@@ -263,8 +246,7 @@
+ WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
+ )
+ add_custom_target(dist
+- DEPENDS ${ARCHIVE_NAME}.tar.xz
+- DEPENDS catch)
++ DEPENDS ${ARCHIVE_NAME}.tar.xz)
+
+ add_custom_target(rpm
+ DEPENDS dist
diff --git a/debian/patches/2002_fix_default_locale.patch b/debian/patches/2002_fix_default_locale.patch
new file mode 100644
index 0000000..aef32d9
--- /dev/null
+++ b/debian/patches/2002_fix_default_locale.patch
@@ -0,0 +1,16 @@
+Description: Fix use C.UTF-8 as hardcoded internal locale
+ Debian always provides C.UTF-8, only often en_US.UTF-8, and not en_US.utf-8.
+Author: Jonas Smedegaard <dr@jones.dk>
+Last-Update: 2016-12-21
+
+--- a/louloulibs/utils/time.cpp
++++ b/louloulibs/utils/time.cpp
+@@ -24,7 +24,7 @@
+ std::tm t = {};
+ #ifdef HAS_GET_TIME
+ std::istringstream ss(stamp);
+- ss.imbue(std::locale("en_US.utf-8"));
++ ss.imbue(std::locale("C.UTF-8"));
+
+ std::string timezone;
+ ss >> std::get_time(&t, format) >> timezone;
diff --git a/debian/patches/README b/debian/patches/README
new file mode 100644
index 0000000..80c1584
--- /dev/null
+++ b/debian/patches/README
@@ -0,0 +1,3 @@
+0xxx: Grabbed from upstream development.
+1xxx: Possibly relevant for upstream adoption.
+2xxx: Only relevant for official Debian release.
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..3505552
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+2001_cmake_ignore_git.patch
+2002_fix_default_locale.patch