summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/020161125~ad22be4.patch38
-rw-r--r--debian/patches/020161204~eb8f1cb.patch24
-rw-r--r--debian/patches/2001_cmake_ignore_git.patch40
-rw-r--r--debian/patches/README3
-rw-r--r--debian/patches/series3
5 files changed, 108 insertions, 0 deletions
diff --git a/debian/patches/020161125~ad22be4.patch b/debian/patches/020161125~ad22be4.patch
new file mode 100644
index 0000000..46013bc
--- /dev/null
+++ b/debian/patches/020161125~ad22be4.patch
@@ -0,0 +1,38 @@
+Description: Do not fail to build if litesql is not there
+Origin: upstream, https://lab.louiz.org/louiz/biboumi/commit/ad22be4
+Author: louiz’ <louiz@louiz.org>
+Forwarded: yes
+Last-Update: 2016-12-21
+
+--- a/src/main.cpp
++++ b/src/main.cpp
+@@ -12,7 +12,9 @@
+
+ #include <atomic>
+ #include <signal.h>
+-#include <litesql.hpp>
++#ifdef USE_DATABASE
++# include <litesql.hpp>
++#endif
+
+ // A flag set by the SIGINT signal handler.
+ static std::atomic<bool> stop(false);
+@@ -83,11 +85,14 @@
+ if (hostname.empty())
+ return config_help("hostname");
+
++
++#ifdef USE_DATABASE
+ try {
+- open_database();
+- } catch (const litesql::DatabaseError&) {
+- return 1;
+- }
++ open_database();
++ } catch (const litesql::DatabaseError&) {
++ return 1;
++ }
++#endif
+
+ // Block the signals we want to manage. They will be unblocked only during
+ // the epoll_pwait or ppoll calls. This avoids some race conditions,
diff --git a/debian/patches/020161204~eb8f1cb.patch b/debian/patches/020161204~eb8f1cb.patch
new file mode 100644
index 0000000..e303cbc
--- /dev/null
+++ b/debian/patches/020161204~eb8f1cb.patch
@@ -0,0 +1,24 @@
+Description: Avoid a potential nullptr dereference
+Origin: upstream, https://lab.louiz.org/louiz/biboumi/commit/eb8f1cb
+Author: louiz’ <louiz@louiz.org>
+Forwarded: yes
+Last-Update: 2016-12-21
+
+--- a/src/xmpp/biboumi_component.cpp
++++ b/src/xmpp/biboumi_component.cpp
+@@ -570,13 +570,11 @@
+ Jid to(stanza.get_tag("to"));
+
+ const XmlNode* query = stanza.get_child("query", MAM_NS);
+- std::string query_id;
+- if (query)
+- query_id = query->get_tag("queryid");
+
+ Iid iid(to.local, {'#', '&'});
+- if (iid.type == Iid::Type::Channel && to.resource.empty())
++ if (query && iid.type == Iid::Type::Channel && to.resource.empty())
+ {
++ const std::string query_id = query->get_tag("queryid");
+ std::string start;
+ std::string end;
+ const XmlNode* x = query->get_child("x", DATAFORM_NS);
diff --git a/debian/patches/2001_cmake_ignore_git.patch b/debian/patches/2001_cmake_ignore_git.patch
new file mode 100644
index 0000000..4334d0f
--- /dev/null
+++ b/debian/patches/2001_cmake_ignore_git.patch
@@ -0,0 +1,40 @@
+Description: Avoid cmake messing with git
+Author: Jonas Smedegaard <dr@jones.dk>
+Last-Update: 2016-12-21
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -198,23 +198,6 @@
+ database)
+ endif()
+
+-include(ExternalProject)
+-ExternalProject_Add(catch
+- GIT_REPOSITORY "https://lab.louiz.org/louiz/Catch.git"
+- PREFIX "external"
+- UPDATE_COMMAND ""
+- CONFIGURE_COMMAND ""
+- BUILD_COMMAND ""
+- INSTALL_COMMAND ""
+- )
+-set_target_properties(catch PROPERTIES EXCLUDE_FROM_ALL TRUE)
+-ExternalProject_Get_Property(catch SOURCE_DIR)
+-if(NOT EXISTS ${CMAKE_SOURCE_DIR}/tests/catch.hpp)
+- target_include_directories(test_suite
+- PUBLIC "${SOURCE_DIR}/include/"
+- )
+- add_dependencies(test_suite catch)
+-endif()
+ add_custom_target(check COMMAND "test_suite"
+ DEPENDS test_suite biboumi)
+ add_custom_target(e2e COMMAND "python3" "${CMAKE_CURRENT_SOURCE_DIR}/tests/end_to_end/"
+@@ -263,8 +246,7 @@
+ WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
+ )
+ add_custom_target(dist
+- DEPENDS ${ARCHIVE_NAME}.tar.xz
+- DEPENDS catch)
++ DEPENDS ${ARCHIVE_NAME}.tar.xz)
+
+ add_custom_target(rpm
+ DEPENDS dist
diff --git a/debian/patches/README b/debian/patches/README
new file mode 100644
index 0000000..80c1584
--- /dev/null
+++ b/debian/patches/README
@@ -0,0 +1,3 @@
+0xxx: Grabbed from upstream development.
+1xxx: Possibly relevant for upstream adoption.
+2xxx: Only relevant for official Debian release.
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..66f0cf4
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,3 @@
+020161125~ad22be4.patch
+020161204~eb8f1cb.patch
+2001_cmake_ignore_git.patch