summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/020161125~ad22be4.patch38
-rw-r--r--debian/patches/020161204~eb8f1cb.patch24
-rw-r--r--debian/patches/2001_cmake_ignore_git.patch16
-rw-r--r--debian/patches/series2
4 files changed, 10 insertions, 70 deletions
diff --git a/debian/patches/020161125~ad22be4.patch b/debian/patches/020161125~ad22be4.patch
deleted file mode 100644
index 46013bc..0000000
--- a/debian/patches/020161125~ad22be4.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Description: Do not fail to build if litesql is not there
-Origin: upstream, https://lab.louiz.org/louiz/biboumi/commit/ad22be4
-Author: louiz’ <louiz@louiz.org>
-Forwarded: yes
-Last-Update: 2016-12-21
-
---- a/src/main.cpp
-+++ b/src/main.cpp
-@@ -12,7 +12,9 @@
-
- #include <atomic>
- #include <signal.h>
--#include <litesql.hpp>
-+#ifdef USE_DATABASE
-+# include <litesql.hpp>
-+#endif
-
- // A flag set by the SIGINT signal handler.
- static std::atomic<bool> stop(false);
-@@ -83,11 +85,14 @@
- if (hostname.empty())
- return config_help("hostname");
-
-+
-+#ifdef USE_DATABASE
- try {
-- open_database();
-- } catch (const litesql::DatabaseError&) {
-- return 1;
-- }
-+ open_database();
-+ } catch (const litesql::DatabaseError&) {
-+ return 1;
-+ }
-+#endif
-
- // Block the signals we want to manage. They will be unblocked only during
- // the epoll_pwait or ppoll calls. This avoids some race conditions,
diff --git a/debian/patches/020161204~eb8f1cb.patch b/debian/patches/020161204~eb8f1cb.patch
deleted file mode 100644
index e303cbc..0000000
--- a/debian/patches/020161204~eb8f1cb.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Description: Avoid a potential nullptr dereference
-Origin: upstream, https://lab.louiz.org/louiz/biboumi/commit/eb8f1cb
-Author: louiz’ <louiz@louiz.org>
-Forwarded: yes
-Last-Update: 2016-12-21
-
---- a/src/xmpp/biboumi_component.cpp
-+++ b/src/xmpp/biboumi_component.cpp
-@@ -570,13 +570,11 @@
- Jid to(stanza.get_tag("to"));
-
- const XmlNode* query = stanza.get_child("query", MAM_NS);
-- std::string query_id;
-- if (query)
-- query_id = query->get_tag("queryid");
-
- Iid iid(to.local, {'#', '&'});
-- if (iid.type == Iid::Type::Channel && to.resource.empty())
-+ if (query && iid.type == Iid::Type::Channel && to.resource.empty())
- {
-+ const std::string query_id = query->get_tag("queryid");
- std::string start;
- std::string end;
- const XmlNode* x = query->get_child("x", DATAFORM_NS);
diff --git a/debian/patches/2001_cmake_ignore_git.patch b/debian/patches/2001_cmake_ignore_git.patch
index 4334d0f..eb2be01 100644
--- a/debian/patches/2001_cmake_ignore_git.patch
+++ b/debian/patches/2001_cmake_ignore_git.patch
@@ -4,10 +4,12 @@ Last-Update: 2016-12-21
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -198,23 +198,6 @@
- database)
- endif()
+@@ -282,27 +282,6 @@
+ endforeach()
+ #
+-## Add a rule to download the catch unit test framework
+-#
-include(ExternalProject)
-ExternalProject_Add(catch
- GIT_REPOSITORY "https://lab.louiz.org/louiz/Catch.git"
@@ -25,10 +27,12 @@ Last-Update: 2016-12-21
- )
- add_dependencies(test_suite catch)
-endif()
+-
+-#
+ ## Add some custom rules to launch the tests
+ #
add_custom_target(check COMMAND "test_suite"
- DEPENDS test_suite biboumi)
- add_custom_target(e2e COMMAND "python3" "${CMAKE_CURRENT_SOURCE_DIR}/tests/end_to_end/"
-@@ -263,8 +246,7 @@
+@@ -362,8 +341,7 @@
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
)
add_custom_target(dist
diff --git a/debian/patches/series b/debian/patches/series
index 66f0cf4..9da3ec6 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1 @@
-020161125~ad22be4.patch
-020161204~eb8f1cb.patch
2001_cmake_ignore_git.patch