summaryrefslogtreecommitdiff
path: root/debian/control
diff options
context:
space:
mode:
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control47
1 files changed, 47 insertions, 0 deletions
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..18d7fd7
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,47 @@
+Source: biboumi
+Section: net
+Priority: optional
+Build-Depends: cdbs,
+ debhelper,
+ dh-buildinfo,
+ cmake,
+ catch,
+ uuid-dev,
+ pandoc,
+ libexpat1-dev,
+ libidn11-dev,
+ libsystemd-dev,
+ libudns-dev,
+ libgcrypt20-dev,
+ libsqlite3-dev
+Maintainer: Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>
+Uploaders: Jonas Smedegaard <dr@jones.dk>,
+ Vasudev Kamath <vasudev@copyninja.info>
+Standards-Version: 4.0.0
+Vcs-Git: https://anonscm.debian.org/git/pkg-voip/biboumi.git
+Vcs-Browser: https://anonscm.debian.org/git/pkg-voip/biboumi.git
+Homepage: https://lab.louiz.org/louiz/biboumi/
+
+Package: biboumi
+Architecture: any
+Depends: ${misc:Depends},
+ ${shlibs:Depends}
+Description: XMPP gateway to connect to IRC servers
+ Biboumi is an XMPP gateway that connects to IRC servers and translates
+ between the two protocols. It can be used to access IRC channels using
+ any XMPP client as if these channels were XMPP MUCs.
+ .
+ It is written in modern C++14 and makes great efforts to have as little
+ dependencies and to be as simple as possible.
+ .
+ The goal is to provide a way to access most of IRC features using any
+ XMPP client. It doesn’t however try to provide a complete mapping of
+ the features of both worlds simply because this is not useful and most
+ probably impossible. For example all IRC modes are not all
+ translatable into an XMPP features. Some of them are (like +m (mute)
+ or +o (operator) modes), but some others are IRC-specific. If IRC is
+ the limiting factor (for example you cannot have a non-ASCII nickname
+ on IRC) then biboumi doesn’t try to work around this issue: it just
+ enforces the rules of the IRC server by telling the user that he/she
+ must choose an ASCII-only nickname. An important goal is to keep the
+ software (and its code) light and simple.