summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f68e7db..14c002c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,8 +21,12 @@ find_package(EXPAT REQUIRED)
find_package(Iconv REQUIRED)
find_package(Libuuid REQUIRED)
find_package(Libidn)
-find_package(SystemdDaemon)
-find_package(Botan)
+if(NOT WITHOUT_SYSTEMD)
+ find_package(SystemdDaemon)
+endif()
+if(NOT WITHOUT_BOTAN)
+ find_package(Botan)
+endif()
#
## Get the software version