summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 90b5432..a71df57 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,6 +21,7 @@ find_package(Iconv REQUIRED)
find_package(Libuuid REQUIRED)
find_package(Libidn)
find_package(SystemdDaemon)
+find_package(Botan)
# To be able to include the config.h file generated by cmake
include_directories("${CMAKE_CURRENT_SOURCE_DIR}/src/")
@@ -37,6 +38,10 @@ if(SYSTEMDDAEMON_FOUND)
include_directories(${SYSTEMDDAEMON_INCLUDE_DIRS})
endif()
+if(BOTAN_FOUND)
+ include_directories(${BOTAN_INCLUDE_DIRS})
+endif()
+
set(POLLER_DOCSTRING "Choose the poller between POLL and EPOLL (Linux-only)")
if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
set(POLLER "EPOLL" CACHE STRING ${POLLER_DOCSTRING})
@@ -95,6 +100,9 @@ file(GLOB source_network
src/network/*.[hc]pp)
add_library(network STATIC ${source_network})
target_link_libraries(network logger)
+if(BOTAN_FOUND)
+ target_link_libraries(network ${BOTAN_LIBRARIES})
+endif()
#
## irclib