summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 12 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 808d9e4..a516589 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -74,10 +74,18 @@ include_directories(${ICONV_INCLUDE_DIRS})
include_directories(${LIBUUID_INCLUDE_DIRS})
# If they are found in louloulibs CMakeLists.txt, we inherite these values
-include_directories(${LIBIDN_INCLUDE_DIRS})
-include_directories(${SYSTEMD_INCLUDE_DIRS})
-include_directories(SYSTEM ${BOTAN_INCLUDE_DIRS})
-include_directories(${CARES_INCLUDE_DIRS})
+if(LIBIDN_FOUND)
+ include_directories(${LIBIDN_INCLUDE_DIRS})
+endif()
+if(SYSTEMD_FOUND)
+ include_directories(${SYSTEMD_INCLUDE_DIRS})
+endif()
+if(BOTAN_FOUND)
+ include_directories(SYSTEM ${BOTAN_INCLUDE_DIRS})
+endif()
+if(CARES_FOUND)
+ include_directories(${CARES_INCLUDE_DIRS})
+endif()
#
## irclib