summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 85c4138..84d9be9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,7 @@ find_package(Iconv REQUIRED)
include(FindEXPAT)
find_package(EXPAT REQUIRED)
find_package(Libidn)
+find_package(SystemdDaemon)
# To be able to include the config.h file generated by cmake
include_directories("src/")
@@ -31,6 +32,12 @@ else()
message("Building without stringprep support.")
endif()
+if(SYSTEMDDAEMON_FOUND)
+ include_directories(${SYSTEMDDAEMON_INCLUDE_DIRS})
+else()
+ message("Building without systemd daemon support.")
+endif()
+
set(POLLER "POLL" CACHE STRING
"Choose the poller between POLL and EPOLL (Linux-only)")
if((NOT ${POLLER} MATCHES "POLL") AND
@@ -124,6 +131,9 @@ target_link_libraries(${PROJECT_NAME}
bridge
utils
config)
+if(SYSTEMDDAEMON_FOUND)
+ target_link_libraries(xmpp ${SYSTEMDDAEMON_LIBRARIES})
+endif()
if(WITH_DOC)
add_dependencies(${PROJECT_NAME} doc)
endif()