summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bb13460..4559201 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -267,6 +267,12 @@ else()
set(SYSTEMD_SERVICE_TYPE "simple")
set(WATCHDOG_SEC "")
endif()
+if(NOT DEFINED SERVICE_USER)
+ set(SERVICE_USER "nobody")
+endif()
+if(NOT DEFINED SERVICE_GROUP)
+ set(SERVICE_GROUP "nobody")
+endif()
configure_file(unit/biboumi.service.cmake biboumi.service)
# The date MUST be in english format